Auto-detect of Python3

You think you found a bug, but you're not sure... or maybe you know you found a bug!

Auto-detect of Python3

Postby AlanObject » Tue May 05, 2015 5:53 pm

I use Mac OS 10.10.3 and NBPython under NB 8.0.2.

Upon installation the plug-ins successfully detect the Python 2.7 framework. However I want to work exclusively in Python 3 (3.4 currently) and that did not auto-detect.

With what is delivered from Apple plus using the standard Python 3 installer you end up with the frameworks in two different places:

/Library/Frameworks/Python.framework/Versions/3.4/bin/python3
/System/Library/Frameworks/Python.framework/Versions/2.7/

The work around is to install the platform manually and it works fine.
AlanObject
 
Posts: 5
Joined: Mon May 04, 2015 9:28 pm

Re: Auto-detect of Python3

Postby mr_lou_d » Wed May 06, 2015 9:45 pm

Alan,

Thanks for the information. I am currently rewriting the Autodetect feature, and will add this to my "standard locations". Very strange (to me) that 2.x is in /System/Library/Frameworks..... and 3.x is in /Library/Frameworks... but I have seen this reported by other Mac users.

I have added AlanObject to the NBPython Developers group. You can post in the appropriate forums there, and I will post when the newer build is available at NetBeans.org.

Welcome!
User avatar
mr_lou_d
Site Admin
 
Posts: 237
Joined: Thu May 22, 2014 11:36 am
Location: Chicago, IL, USA


Return to Anomalies (Bugs)



Who is online

Users browsing this forum: No registered users and 1 guest

cron